Open Broadcast Software no Debian Jessie

De MochilaWiki

ajustando repositório

É necessário ter no sources.list

deb http://ftp.br.debian.org/debian jessie main contrib non-free

instalando dependências

sudo apt-get install libx11-dev libgl1-mesa-dev libpulse-dev libxcomposite-dev \
libxinerama-dev libv4l-dev libudev-dev libfreetype6-dev \
libfontconfig1-dev qtbase5-dev libqt5x11extras5-dev libx264-dev \
libxcb-xinerama0-dev libxcb-shm0-dev libjack-jackd2-dev libcurl4-openssl-dev \
build-essential pkg-config cmake git checkinstall libfdk-aac-dev yasm

compilando FFmpeg - GiT

git clone --depth 1 git://source.ffmpeg.org/ffmpeg.git
cd ffmpeg
./configure --enable-shared --prefix=/usr
make -j4
sudo checkinstall --pkgname=FFmpeg --fstrans=no --backup=no --pkgversion="$(date +%Y%m%d)-git" --deldoc=yes
sudo dpkg -i ffmpeg*.deb

compilando OBS - GiT

git clone https://github.com/jp9000/obs-studio.git
cd obs-studio
mkdir build && cd build
cmake -DUNIX_STRUCTURE=1 -DCMAKE_INSTALL_PREFIX=/usr ..
make -j4
sudo checkinstall --pkgname=obs-studio --fstrans=no --backup=no --pkgversion="$(date +%Y%m%d)-git" --deldoc=yes
sudo dpkg -i obs-studio_*.deb

FFmpeg e OBS compilado

sudo apt-get install libqt5widgets5 libxcb-shm0 libjack-jackd2-0 libcurl3 libxcb-xinerama0 libqt5x11extras5
wget http://pub.nkosi.org/floema/obs/ffmpeg_20151230-git-1_amd64.deb
wget http://pub.nkosi.org/floema/obs/obs-studio_20151230-git-1_amd64.deb
sudo dpkg -i obs-studio_20151230-git-1_amd64.deb ffmpeg_20151230-git-1_amd64.deb


Se der erro tente make -j4 ou aumente a memoria swap para 1G

dd if=/dev/zero of=/var/swap.img bs=1024k count=1000
mkswap /var/swap.img
chmod 0600 /var/swap.img
swapon /var/swap.img

Referências